<!doctype html>
<html lang="en-US">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, initial-scale=1">
<link rel="profile" href="http://gmpg.org/xfn/11">
<title>UPDATED: Education Act compromise cools NSTU&#8217;s job action threat &#8211; Enfield Weekly Press</title>
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Enfield Weekly Press &raquo; Feed" href="http://enfieldweeklypress.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Enfield Weekly Press &raquo; Comments Feed" href="http://enfieldweeklypress.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Enfield Weekly Press &raquo; iCal Feed" href="http://enfieldweeklypress.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Enfield Weekly Press &raquo; UPDATED: Education Act compromise cools NSTU&#8217;s job action threat Comments Feed" href="http://enfieldweeklypress.com/2018/03/01/education-reform-act-to-be-introduced-by-churchill/feed/" />
<!-- <link rel='stylesheet' id='tribe-events-full-calendar-style-css'  href='//d1uoof821imlo6.cloudfront.net/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-full.min.css?ver=4.6.11.1' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='tribe-events-calendar-style-css'  href='//d1uoof821imlo6.cloudfront.net/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-theme.min.css?ver=4.6.11.1' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//d1uoof821imlo6.cloudfront.net/wp-content/cache/wpfc-minified/ab1678268edd49032ed11a854234907d/1519929100index.css" media="all"/>
<!-- <link rel='stylesheet' id='tribe-events-calendar-full-mobile-style-css'  href='//d1uoof821imlo6.cloudfront.net/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-full-mobile.min.css?ver=4.6.11.1' type='text/css' media='only screen and (max-width: 768px)' /> -->
<!-- <link rel='stylesheet' id='tribe-events-calendar-mobile-style-css'  href='//d1uoof821imlo6.cloudfront.net/wp-content/plugins/the-events-calendar/src/resources/css/tribe-events-theme-mobile.min.css?ver=4.6.11.1' type='text/css' media='only screen and (max-width: 768px)' /> -->
<link rel="stylesheet" type="text/css" href="//d1uoof821imlo6.cloudfront.net/wp-content/cache/wpfc-minified/10b5d449f596e4aca3720db46697134b/1519929100index.css" media="only screen and (max-width: 768px)"/>
<link rel='stylesheet' id='news-portal-fonts-css'  href='https://fonts.googleapis.com/css?family=Roboto+Condensed%3A300italic%2C400italic%2C700italic%2C400%2C300%2C700%7CRoboto%3A300%2C400%2C400i%2C500%2C700%7CTitillium+Web%3A400%2C600%2C700%2C300&#038;subset=latin%2Clatin-ext' type='text/css' media='all' />
<!-- <link rel='stylesheet' id='font-awesome-css'  href='//d1uoof821imlo6.cloudfront.net/wp-content/themes/news-portal/assets/library/font-awesome/css/font-awesome.min.css?ver=4.7.0' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='lightslider-style-css'  href='//d1uoof821imlo6.cloudfront.net/wp-content/themes/news-portal/assets/library/lightslider/css/lightslider.min.css?ver=1.1.6' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='news-portal-style-css'  href='//d1uoof821imlo6.cloudfront.net/wp-content/themes/news-portal/style.css?ver=1.1.1' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//d1uoof821imlo6.cloudfront.net/wp-content/cache/wpfc-minified/49886eb143d5126426a2e81d10fe23c4/1519929100index.css" media="all"/>
<style id='news-portal-style-inline-css' type='text/css'>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</style>
<!-- <link rel='stylesheet' id='news-portal-responsive-style-css'  href='//d1uoof821imlo6.cloudfront.net/wp-content/themes/news-portal/assets/css/np-responsive.css?ver=1.0.0' type='text/css' media='all' /> -->
<!-- <link rel='stylesheet' id='__EPYT__style-css'  href='//d1uoof821imlo6.cloudfront.net/wp-content/plugins/youtube-embed-plus/styles/ytprefs.min.css?ver=4.9.4' type='text/css' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//d1uoof821imlo6.cloudfront.net/wp-content/cache/wpfc-minified/469c9eacea50888053ad00f4c356106a/1519929100index.css" media="all"/>
<style id='__EPYT__style-inline-css' type='text/css'>
.epyt-gallery-thumb {
width: 33.333%;
}
</style>
<script type='text/javascript'>
/* <![CDATA[ */
var _EPYT_ = {"ajaxurl":"http:\/\/enfieldweeklypress.com\/wp-admin\/admin-ajax.php","security":"fe2f13915c","gallery_scrolloffset":"20","eppathtoscripts":"http:\/\/enfieldweeklypress.com\/wp-content\/plugins\/youtube-embed-plus\/scripts\/","epresponsiveselector":"[\"iframe.__youtube_prefs_widget__\"]","epdovol":"1","version":"11.8.5","evselector":"iframe.__youtube_prefs__[src], iframe[src*=\"youtube.com\/embed\/\"], iframe[src*=\"youtube-nocookie.com\/embed\/\"]","ajax_compat":"","stopMobileBuffer":"1"};
/* ]]> */
</script>
<script src='//d1uoof821imlo6.cloudfront.net/wp-content/cache/wpfc-minified/ac9a05d76222864a38edc53561e9fb8a/1519929100index.js' type="text/javascript"></script>
<!-- <script type='text/javascript' src='//d1uoof821imlo6.cloudfront.net/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script> -->
<!-- <script type='text/javascript' src='//d1uoof821imlo6.cloudfront.net/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script> -->
<!-- <script type='text/javascript' src='//d1uoof821imlo6.cloudfront.net/wp-content/plugins/youtube-embed-plus/scripts/ytprefs.min.js?ver=4.9.4'></script> -->
<link rel='https://api.w.org/' href='http://enfieldweeklypress.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://enfieldweeklypress.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://enfieldweeklypress.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Olympic flame lit at MVEC' href='http://enfieldweeklypress.com/2018/03/01/olympic-flame-lit-at-mvec/' />
<meta name="generator" content="WordPress 4.9.4" />
<link rel="canonical" href="http://enfieldweeklypress.com/2018/03/01/education-reform-act-to-be-introduced-by-churchill/" />
<link rel='shortlink' href='http://enfieldweeklypress.com/?p=768' />
<link rel="alternate" type="application/json+oembed" href="http://enfieldweeklypress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fenfieldweeklypress.com%2F2018%2F03%2F01%2Feducation-reform-act-to-be-introduced-by-churchill%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://enfieldweeklypress.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fenfieldweeklypress.com%2F2018%2F03%2F01%2Feducation-reform-act-to-be-introduced-by-churchill%2F&#038;format=xml" />
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="http://enfieldweeklypress.com"><link rel="https://theeventscalendar.com/" href="http://enfieldweeklypress.com/wp-json/tribe/events/v1/" /><link rel="pingback" href="http://enfieldweeklypress.com/xmlrpc.php"><style type="text/css" id="custom-background-css">
body.custom-background { background-image: url("//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/Enfield-Weekly-Press-BG.jpg"); background-position: left top; background-size: auto; background-repeat: repeat; background-attachment: fixed; }
</style>
<link rel="icon" href="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/EWP-logo-04.jpg" sizes="32x32" />
<link rel="icon" href="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/EWP-logo-04.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/EWP-logo-04.jpg" />
<meta name="msapplication-TileImage" content="http://enfieldweeklypress.com/wp-content/uploads/2018/02/EWP-logo-04.jpg" />
<style type="text/css" id="wp-custom-css">
.custom-logo {
/* 	width:700px; */
/* 	height:158px; */
/* 	padding-left:200px; */
}
.np-logo-section-wrapper {
background-color: #252525;
}
.np-article-thumb {
width:500px;
/* 	height:2%; */
/* 	float:left; */
}
.np-archive-post-content-wrapper {
/* 	overflow:hidden; */
padding-top:1px;
padding-bottom:1px;
}
.np-archive-more {
display:none;
}
div.entry-content p {
margin-bottom:0px;
}
.entry-footer {
margin-top:1px;
}
@media screen and (max-width: 735px) {
.np-ticker-block {
display: none;
}
}		</style>
<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css">
<style>
* {
box-sizing: border-box;
}
div.example input[type=text] {
padding: 10px;
font-size: 17px;
border: 1px solid grey;
float: left;
width: 80%;
height: 48px;
background: #f1f1f1;
}
div.example button {
float: left;
width: 20%;
height: 48px;
padding: 10px;
background: purple;
color: white;
font-size: 17px;
border: 1px solid grey;
border-left: none;
cursor: pointer;
}
div.example button:hover {
background: rgb(255, 0, 255);
}
div.example::after {
content: "";
clear: both;
display: table;
}
div.example b, strong {
color: purple;
}
div.example h6 {
font-size: 14px;
}
</style>
</head>
<body class="post-template-default single single-post postid-768 single-format-standard custom-background wp-custom-logo tribe-no-js group-blog right-sidebar boxed_layout">
<div id="page" class="site">
<div class="np-top-header-wrap"><div class="mt-container">		<div class="np-top-left-section-wrapper">
<div class="date-section">Thursday, March 01, 2018</div>
<nav id="top-navigation" class="top-navigation" role="navigation">
<div class="menu-small-container"><ul id="top-menu" class="menu"><li id="menu-item-24" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24"><a href="http://enfieldweeklypress.com/contact/">Contact</a></li>
<li id="menu-item-25" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25"><a href="http://enfieldweeklypress.com/faq/">FAQ</a></li>
</ul></div>				</nav><!-- #site-navigation -->
</div><!-- .np-top-left-section-wrapper -->
<div class="np-top-right-section-wrapper">
<div class="mt-social-icons-wrapper"><span class="social-link"><a href="https://www.facebook.com/EnfieldWeeklyPress/%20" target="_blank"><i class="fa fa-facebook-f"></i></a></span><span class="social-link"><a href="https://twitter.com/weeklypressnews?lang=en" target="_blank"><i class="fa fa-twitter"></i></a></span></div><!-- .mt-social-icons-wrapper -->		</div><!-- .np-top-right-section-wrapper -->
</div><!-- .mt-container --></div><!-- .np-top-header-wrap -->
<header id="masthead" class="site-header" role="banner"><div class="np-logo-section-wrapper"><div class="mt-container">		<div class="site-branding">
<a href="http://enfieldweeklypress.com/" class="custom-logo-link" rel="home" itemprop="url"><img width="683" height="158" src="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/EWP-logo-03-1.png" class="custom-logo" alt="Enfield Weekly Press" itemprop="logo" srcset="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/EWP-logo-03-1.png 683w, //d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/EWP-logo-03-1-300x69.png 300w" sizes="(max-width: 683px) 100vw, 683px" /></a>
<p class="site-title"><a href="http://enfieldweeklypress.com/" rel="home">Enfield Weekly Press</a></p>
<p class="site-description">Just another WordPress site</p>
</div><!-- .site-branding -->
<div class="np-header-ads-area">
</div><!-- .np-header-ads-area -->
</div><!-- .mt-container --></div><!-- .np-logo-section-wrapper -->		<div id="np-menu-wrap" class="np-header-menu-wrapper">
<div class="np-header-menu-block-wrap">
<div class="mt-container">
<a href="javascript:void(0)" class="menu-toggle hide"> <i class="fa fa-navicon"> </i> </a>
<nav id="site-navigation" class="main-navigation" role="navigation">
<div class="menu-main-container"><ul id="primary-menu" class="menu"><li id="menu-item-27" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-27"><a href="http://enfieldweeklypress.com/">Home</a></li>
<li id="menu-item-55" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-55"><a href="#">News</a>
<ul class="sub-menu">
<li id="menu-item-29" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-29"><a href="http://enfieldweeklypress.com/category/community/">Community</a></li>
<li id="menu-item-35" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-35"><a href="http://enfieldweeklypress.com/category/sports/">Sports</a></li>
<li id="menu-item-28" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28"><a href="http://enfieldweeklypress.com/category/art-entertainment/">Arts &#038; Entertainment</a></li>
</ul>
</li>
<li id="menu-item-33" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-33"><a href="http://enfieldweeklypress.com/category/online-first/">Online First</a></li>
<li id="menu-item-34" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34"><a href="http://enfieldweeklypress.com/category/opinions/">Opinions</a></li>
<li id="menu-item-32" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-32"><a href="http://enfieldweeklypress.com/category/obituaries/">Obituaries</a></li>
<li id="menu-item-56" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-56"><a href="#">Gallery</a>
<ul class="sub-menu">
<li id="menu-item-141" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-141"><a href="http://enfieldweeklypress.com/photos/">Photos</a></li>
<li id="menu-item-36" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-36"><a href="http://enfieldweeklypress.com/category/videos/">Videos</a></li>
</ul>
</li>
<li id="menu-item-321" class="menu-item menu-item-type-taxonomy menu-item-object-tribe_events_cat menu-item-321"><a href="http://enfieldweeklypress.com/events/category/events/">Events</a></li>
<li id="menu-item-26" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26"><a href="http://enfieldweeklypress.com/archives/">Archives</a></li>
</ul></div>					</nav><!-- #site-navigation -->
<div class="np-header-search-wrapper">                    
<span class="search-main"><i class="fa fa-search"></i></span>
<div class="search-form-main np-clearfix">
<form role="search" method="get" class="search-form" action="http://enfieldweeklypress.com/">
<label>
<span class="screen-reader-text">Search for:</span>
<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
</label>
<input type="submit" class="search-submit" value="Search" />
</form>				            </div>
</div><!-- .np-header-search-wrapper -->
</div>
</div>
</div><!-- .np-header-menu-wrapper -->
</header><!-- .site-header -->
<div id="content" class="site-content">
<div class="mt-container">
<div id="primary" class="content-area">
<main id="main" class="site-main" role="main">
<article id="post-768" class="post-768 post type-post status-publish format-standard has-post-thumbnail hentry category-community category-featured category-online-first tag-east-hants tag-education tag-liberals tag-n-s tag-nstu">
<div class="np-article-thumb">
<img width="600" height="400" src="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/hal108_20150902296021_high-e1518619317832.jpg" class="attachment-full size-full wp-post-image" alt="" />			</div><!-- .np-article-thumb -->
<header class="entry-header">
<h1 class="entry-title">UPDATED: Education Act compromise cools NSTU&#8217;s job action threat</h1>		<div class="post-cats-list">
<span class="category-button np-cat-5"><a href="http://enfieldweeklypress.com/category/community/">Community</a></span>
<span class="category-button np-cat-19"><a href="http://enfieldweeklypress.com/category/featured/">Featured</a></span>
<span class="category-button np-cat-4"><a href="http://enfieldweeklypress.com/category/online-first/">Online First</a></span>
</div>
<div class="entry-meta">
<span class="posted-on"> <a href="http://enfieldweeklypress.com/2018/03/01/education-reform-act-to-be-introduced-by-churchill/" rel="bookmark"><time class="entry-date published" datetime="2018-03-01T11:08:13+00:00">March 1, 2018</time><time class="updated" datetime="2018-03-01T18:17:51+00:00">March 1, 2018</time></a></span><span class="byline">  <span class="author vcard"><a class="url fn n" href="http://enfieldweeklypress.com/author/patrickh/">Patrick Healey</a></span></span>		</div><!-- .entry-meta -->
</header><!-- .entry-header -->
<div class="entry-content">
<p><em>Act removes seven school boards as of March 31; proposes cooperation with NSTU on several items</em></p>
<p><strong>FALL RIVER: </strong>The province will work with the NSTU on a pair of items as part of the new Education Reform Act it introduced as a new bill on March 1.</p>
<p>In a release, Education Minister Zach Churchill said the province wants to support teaching excellence but will take a different approach to the recommendation in the report by Dr. Avis Glaze on a College of Educators.</p>
<p>The release about the Education Reform Act says the province will work with teachers and the NSTU to develop teaching and leadership standards. Government has also agreed to work with the NSTU on a number of recommendations that focus on areas, including extracurricular activities, professional development, strategies for recruiting teachers, rural education, educational needs of new immigrants, French language education, students living in poverty, and children in care.</p>
<p>Churchill said the act will strengthen the education system and establish a foundation for other improvements, including the Commission on Inclusive Education.</p>
<p>“After hearing for many years that our education system needs to change, we are making foundational reforms that will keep us focused on student success,” said Education and Early Childhood Development Minister Zach Churchill.</p>
<p>To help unify the system, seven elected English school boards will be dissolved as of March 31. The $2.3 million in annual board member stipends and expenses will go back into schools.</p>
<p>Under the proposed legislation, board offices will be renamed regional education centres. They will continue to make the same regional and local decisions they do now. Superintendents will become regional executive directors, reporting to the deputy minister of education.</p>
<p>The Conseil scolaire acadien provincial (CSAP) will remain in place. An act to oversee the CSAP will be introduced later in the session. For the first time, there will be separate legislation for the CSAP, reflecting the cultural and linguistic rights of Acadians and francophones.</p>
<p>A new Provincial Advisory Council of Education will be created. It will have up to 15 members, representing all regions, and diverse communities and backgrounds. A representative with experience in inclusive education will also sit on the council.</p>
<p>Two new executive director positions representing the African Nova Scotian and Mi’kmaw communities are being created at the Department of Education and Early Childhood Development. The department will work with those communities to enhance their voices.</p>
<p>Principals, vice-principals and other senior supervisory staff will move out of the Nova Scotia Teachers Union (NSTU) to a new association called the Public School Administrators Association. This means they are removed from the NSTU bargaining unit and no longer members, but are still affiliated with the NSTU. That affiliation ensures seniority and compensation are protected, and principals and vice-principals will have the same benefits and pension they do now.</p>
<p>School Advisory Councils will be supported to advance local priorities for their communities. Consultations with current members will be held this spring to determine details such as their structure, membership, and supports needed for members.</p>
<p>In addition to the legislative measures, teachers will now have more say in choosing learning resources and textbooks for their classroom. Teaching support specialists will spend less time in regional offices and more time in schools where they will work closer with teachers and students.</p>
<p>“Our vision for students is that they have the same start, and same chance at success once they graduate,” Churchill said. “The changes in the Education Reform Act will strengthen our system to ensure all partners can focus 100 per cent on our kids.”</p>
<p>NSTU President Liette Doucet held a press conference this afternoon saying the compromises made by the province had been enough to ensure they do not pursue job action.</p>
<p>“A college of teachers and a central department of evaluations would have created more<br />
unnecessary bureaucracy and would have drained resources from our schools. It is<br />
positive those ideas have been rejected,” said Doucet. “Similarly, a province-wide seniority list would place rural communities as risk, so we are pleased that concept is now being reconsidered.”</p>
<p>She said the Teachers Union remains opposed to the legislation.</p>
<p>“The collegial model is badly damaged with the removal of administrators from our<br />
bargaining unit, and I fear this could bring more conflict to our schools,&#8221; she said. &#8220;Similarly, I am genuinely fearful of the chaos that the elimination of English school boards will bring to<br />
the entire system.</p>
<p>&#8220;This approach has not served our health care system well.&#8221;</p>
<p>Doucet wanted to thank parents, students and community members for their overwhelming<br />
support in recent weeks. She said a powerful message teachers presented with their strike mandate helped raise awareness of the risks that came from implementing the Glaze Report.</p>
<p>“Teachers have been united in opposing changes outlined in the Glaze report, and their<br />
collective voice has begun to open the eyes and ears of government to the challenges our<br />
students are facing,&#8221; said Doucet. &#8220;We are well aware of the short-term impact a strike would have on families, and while the government has done enough to avert job action, they still have much more to do to improve our public education system.</p>
<p>&#8220;We will hold them accountable.”</p>
</div><!-- .entry-content -->
<footer class="entry-footer">
<span class="tags-links">Tagged <a href="http://enfieldweeklypress.com/tag/east-hants/" rel="tag">East Hants</a> <a href="http://enfieldweeklypress.com/tag/education/" rel="tag">education</a> <a href="http://enfieldweeklypress.com/tag/liberals/" rel="tag">Liberals</a> <a href="http://enfieldweeklypress.com/tag/n-s/" rel="tag">N.S.</a> <a href="http://enfieldweeklypress.com/tag/nstu/" rel="tag">NSTU</a></span>	</footer><!-- .entry-footer -->
</article><!-- #post-768 -->
<nav class="navigation post-navigation" role="navigation">
<h2 class="screen-reader-text">Post navigation</h2>
<div class="nav-links"><div class="nav-previous"><a href="http://enfieldweeklypress.com/2018/03/01/olympic-flame-lit-at-mvec/" rel="prev">Olympic flame lit at MVEC</a></div></div>
</nav><div class="np-related-section-wrapper"><h2 class="np-related-title np-clearfix">Related Posts</h2><div class="np-related-posts-wrap np-clearfix">				<div class="np-single-post np-clearfix">
<div class="np-post-thumb">
<a href="http://enfieldweeklypress.com/2018/02/15/impaired-driving-stats-stable-across-east-hants-musq-valley/">
<img width="305" height="207" src="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/rcmp-logo-305x207.jpg" class="attachment-news-portal-block-medium size-news-portal-block-medium wp-post-image" alt="" srcset="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/rcmp-logo-305x207.jpg 305w, //d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/rcmp-logo-622x420.jpg 622w" sizes="(max-width: 305px) 100vw, 305px" />						</a>
</div><!-- .np-post-thumb -->
<div class="np-post-content">
<h3 class="np-post-title small-size"><a href="http://enfieldweeklypress.com/2018/02/15/impaired-driving-stats-stable-across-east-hants-musq-valley/">Impaired driving stats stable across East Hants, Musq. Valley</a></h3>
<div class="np-post-meta">
<span class="posted-on"> <a href="http://enfieldweeklypress.com/2018/02/15/impaired-driving-stats-stable-across-east-hants-musq-valley/" rel="bookmark"><time class="entry-date published" datetime="2018-02-15T08:35:52+00:00">February 15, 2018</time><time class="updated" datetime="2018-02-14T17:33:37+00:00">February 14, 2018</time></a></span><span class="byline">  <span class="author vcard"><a class="url fn n" href="http://enfieldweeklypress.com/author/patrickh/">Patrick Healey</a></span></span>						</div>
</div><!-- .np-post-content -->
</div><!-- .np-single-post -->
<div class="np-single-post np-clearfix">
<div class="np-post-thumb">
<a href="http://enfieldweeklypress.com/2018/02/21/alton-gas-reps-visit-site-for-equipment-signage-work/">
<img width="305" height="207" src="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/alton-1-305x207.jpg" class="attachment-news-portal-block-medium size-news-portal-block-medium wp-post-image" alt="" srcset="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/alton-1-305x207.jpg 305w, //d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/alton-1-622x420.jpg 622w" sizes="(max-width: 305px) 100vw, 305px" />						</a>
</div><!-- .np-post-thumb -->
<div class="np-post-content">
<h3 class="np-post-title small-size"><a href="http://enfieldweeklypress.com/2018/02/21/alton-gas-reps-visit-site-for-equipment-signage-work/">Alton Gas reps visit site  for equipment, signage work</a></h3>
<div class="np-post-meta">
<span class="posted-on"> <a href="http://enfieldweeklypress.com/2018/02/21/alton-gas-reps-visit-site-for-equipment-signage-work/" rel="bookmark"><time class="entry-date published" datetime="2018-02-21T06:00:19+00:00">February 21, 2018</time><time class="updated" datetime="2018-02-20T02:03:13+00:00">February 20, 2018</time></a></span><span class="byline">  <span class="author vcard"><a class="url fn n" href="http://enfieldweeklypress.com/author/patrickh/">Patrick Healey</a></span></span>						</div>
</div><!-- .np-post-content -->
</div><!-- .np-single-post -->
<div class="np-single-post np-clearfix">
<div class="np-post-thumb">
<a href="http://enfieldweeklypress.com/2018/02/14/halifax-stanfield-holding-contest/">
<img width="305" height="207" src="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/Placeholder-EWP-News-305x207.jpg" class="attachment-news-portal-block-medium size-news-portal-block-medium wp-post-image" alt="" srcset="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/Placeholder-EWP-News-305x207.jpg 305w, //d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/Placeholder-EWP-News-622x420.jpg 622w" sizes="(max-width: 305px) 100vw, 305px" />						</a>
</div><!-- .np-post-thumb -->
<div class="np-post-content">
<h3 class="np-post-title small-size"><a href="http://enfieldweeklypress.com/2018/02/14/halifax-stanfield-holding-contest/">Halifax Stanfield holding contest</a></h3>
<div class="np-post-meta">
<span class="posted-on"> <a href="http://enfieldweeklypress.com/2018/02/14/halifax-stanfield-holding-contest/" rel="bookmark"><time class="entry-date published" datetime="2018-02-14T07:15:21+00:00">February 14, 2018</time><time class="updated" datetime="2018-02-14T18:45:27+00:00">February 14, 2018</time></a></span><span class="byline">  <span class="author vcard"><a class="url fn n" href="http://enfieldweeklypress.com/author/abbyc/">Abby Cameron</a></span></span>						</div>
</div><!-- .np-post-content -->
</div><!-- .np-single-post -->
</div><!-- .np-related-posts-wrap --></div><!-- .np-related-section-wrapper -->
</main><!-- #main -->
</div><!-- #primary -->
<aside id="secondary" class="widget-area" role="complementary">
<section id="news_portal_ads_banner-5" class="widget news_portal_ads_banner">            <div class="np-ads-wrapper">
<h4 class="widget-title">Advertisments</h4>                                    <a href="http://www.facebook.com/PayzantsHomeHardware/%20" target="_blank" rel=""><img src="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/PayzantAdFeb142018.jpg" /></a>
</div><!-- .np-ads-wrapper -->
</section><section id="news_portal_ads_banner-8" class="widget news_portal_ads_banner">            <div class="np-ads-wrapper">
<img src="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/AntonysFreshmartAdFeb152018.jpg" />
</div><!-- .np-ads-wrapper -->
</section><section id="news_portal_ads_banner-6" class="widget news_portal_ads_banner">            <div class="np-ads-wrapper">
<a href="http://www.brewsterwelldrilling.com" target="_blank" rel=""><img src="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/140170.jpg" /></a>
</div><!-- .np-ads-wrapper -->
</section><section id="tribe-events-list-widget-3" class="widget tribe-events-list-widget"><h4 class="widget-title">Upcoming Events</h4>
<ol class="tribe-list-widget">
<li class="tribe-events-list-widget-events type-tribe_events post-598 tribe-clearfix tribe-events-category-events">
<!-- Event Title -->
<h4 class="tribe-event-title">
<a href="http://enfieldweeklypress.com/event/thursday-night-social/" rel="bookmark">Thursday Night Social</a>
</h4>
<!-- Event Time -->
<div class="tribe-event-duration">
<span class="tribe-event-date-start">March 1 @ 4:00 pm</span> - <span class="tribe-event-time">9:00 pm</span>				</div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-613 tribe-clearfix tribe-events-category-events">
<!-- Event Title -->
<h4 class="tribe-event-title">
<a href="http://enfieldweeklypress.com/event/east-hants-toastmasters-chapter/" rel="bookmark">East Hants Toastmasters Chapter</a>
</h4>
<!-- Event Time -->
<div class="tribe-event-duration">
<span class="tribe-event-date-start">March 1 @ 6:30 pm</span> - <span class="tribe-event-time">8:00 pm</span>				</div>
</li>
<li class="tribe-events-list-widget-events type-tribe_events post-689 tribe-clearfix tribe-events-category-events">
<!-- Event Title -->
<h4 class="tribe-event-title">
<a href="http://enfieldweeklypress.com/event/karate/" rel="bookmark">Karate</a>
</h4>
<!-- Event Time -->
<div class="tribe-event-duration">
<span class="tribe-event-date-start">March 1 @ 6:30 pm</span> - <span class="tribe-event-time">9:00 pm</span>				</div>
</li>
</ol><!-- .tribe-list-widget -->
<p class="tribe-events-widget-link">
<a href="http://enfieldweeklypress.com/events/" rel="bookmark">View All Events</a>
</p>
</section><script type="application/ld+json">
[{"@context":"http://schema.org","@type":"Event","name":"Thursday Night Social","description":"&lt;p&gt;Thursday Night Social at the Wellington Fletcher\u2019s Lake Station House, from 4 - 9 p.m. Cash bar.&lt;/p&gt;\\n","url":"http://enfieldweeklypress.com/event/thursday-night-social/","startDate":"2018-03-01T16:00:00-04:00","endDate":"2018-03-01T21:00:00-04:00"},{"@context":"http://schema.org","@type":"Event","name":"East Hants Toastmasters Chapter","description":"&lt;p&gt;East Hants Toastmasters Chapter: from 6:30 \u2013 8:00 p.m. at Margaret Miller\u2019s office. Toastmasters empower individuals to become more effective communicators and leaders! Still open to new registrations. For information or to register please email stacey.ingraham@rbc.com&lt;/p&gt;\\n","url":"http://enfieldweeklypress.com/event/east-hants-toastmasters-chapter/","startDate":"2018-03-01T18:30:00-04:00","endDate":"2018-03-01T20:00:00-04:00"},{"@context":"http://schema.org","@type":"Event","name":"Karate","description":"&lt;p&gt;Karate at the Nine Mile River Community Centre. Children from 6:30 \u2013 7:30 p.m., adults from 7:30 \u2013 9 p.m. For information, call Chris at 902-497-8232.&lt;/p&gt;\\n","url":"http://enfieldweeklypress.com/event/karate/","startDate":"2018-03-01T18:30:00-04:00","endDate":"2018-03-01T21:00:00-04:00"}]
</script></aside><!-- #secondary -->

</div><!-- .mt-container -->
</div><!-- #content -->
<footer id="colophon" class="site-footer" role="contentinfo">
<div id="top-footer" class="footer-widgets-wrapper footer_column_three np-clearfix">
<div class="mt-container">
<div class="footer-widgets-area np-clearfix">
<div class="np-footer-widget-wrapper np-column-wrapper np-clearfix">
<div class="np-footer-widget wow fadeInLeft" data-wow-duration="0.5s">
<section id="media_image-2" class="widget widget_media_image"><img width="300" height="70" src="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/Advocate-Media-Logo-footer-300x70.png" class="image wp-image-40  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="//d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/Advocate-Media-Logo-footer-300x70.png 300w, //d1uoof821imlo6.cloudfront.net/wp-content/uploads/2018/02/Advocate-Media-Logo-footer.png 360w" sizes="(max-width: 300px) 100vw, 300px" /></section>          		</div>
<div class="np-footer-widget wow fadeInLeft" data-woww-duration="1s">
<section id="text-2" class="widget widget_text"><h4 class="widget-title">About Us</h4>			<div class="textwidget"><p>287 Highway 2, B2T 1C9 Enfield, Nova Scotia</p>
<p>+1 (902) 883-3181 | <a href="mailto:editor@enfieldweeklypress.com">editor@enfieldweeklypress.com</a></p>
</div>
</section>          		</div>
<div class="np-footer-widget wow fadeInLeft" data-wow-duration="1.5s">
<section id="news_portal_social_media-2" class="widget news_portal_social_media">            <div class="np-aside-social-wrapper">
<h4 class="widget-title">Follow Us</h4>                <div class="mt-social-icons-wrapper">
<span class="social-link"><a href="https://www.facebook.com/EnfieldWeeklyPress/%20" target="_blank"><i class="fa fa-facebook-f"></i></a></span><span class="social-link"><a href="https://twitter.com/weeklypressnews?lang=en" target="_blank"><i class="fa fa-twitter"></i></a></span>                </div><!-- .mt-social-icons-wrapper -->
</div><!-- .np-aside-social-wrapper -->
</section>                </div>
</div><!-- .np-footer-widget-wrapper -->
</div><!-- .footer-widgets-area -->
</div><!-- .mt-container -->
</div><!-- .footer-widgets-wrapper --><div class="bottom-footer np-clearfix"><div class="mt-container">		<div class="site-info">
<span class="np-copyright-text">
Enfield Weekly Press			</span>
<span class="sep"> | </span>
Theme: News Portal by <a href="https://mysterythemes.com/" rel="designer" target="_blank">Mystery Themes</a>.		</div><!-- .site-info -->
<nav id="footer-navigation" class="footer-navigation" role="navigation">
<div class="menu-small-container"><ul id="footer-menu" class="menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-24"><a href="http://enfieldweeklypress.com/contact/">Contact</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-25"><a href="http://enfieldweeklypress.com/faq/">FAQ</a></li>
</ul></div>		</nav><!-- #site-navigation -->
</div><!-- .mt-container --></div> <!-- bottom-footer --></footer><!-- #colophon --><div id="np-scrollup" class="animated arrow-hide"><i class="fa fa-chevron-up"></i></div></div><!-- #page -->
<a rel="nofollow" style="display:none;" href="http://enfieldweeklypress.com/?blackhole=5c86ae8aa8" title="Blackhole for Bad Bots">Do NOT follow this link or you will be banned from the site!</a>
<script>
( function ( body ) {
'use strict';
body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
} )( document.body );
</script>
<script type='text/javascript'> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done"}};/* ]]> */ </script><script type='text/javascript' src='//d1uoof821imlo6.cloudfront.net/wp-content/themes/news-portal/assets/js/navigation.js?ver=1.1.1'></script>
<script type='text/javascript' src='//d1uoof821imlo6.cloudfront.net/wp-content/themes/news-portal/assets/library/sticky/jquery.sticky.js?ver=20150416'></script>
<script type='text/javascript' src='//d1uoof821imlo6.cloudfront.net/wp-content/themes/news-portal/assets/library/sticky/sticky-setting.js?ver=20150309'></script>
<script type='text/javascript' src='//d1uoof821imlo6.cloudfront.net/wp-content/themes/news-portal/assets/js/skip-link-focus-fix.js?ver=1.1.1'></script>
<script type='text/javascript' src='//d1uoof821imlo6.cloudfront.net/wp-content/themes/news-portal/assets/library/lightslider/js/lightslider.min.js?ver=1.1.6'></script>
<script type='text/javascript' src='//d1uoof821imlo6.cloudfront.net/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='//d1uoof821imlo6.cloudfront.net/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='//d1uoof821imlo6.cloudfront.net/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4'></script>
<script type='text/javascript' src='//d1uoof821imlo6.cloudfront.net/wp-content/themes/news-portal/assets/js/np-custom-scripts.js?ver=1.1.1'></script>
<script type='text/javascript' src='//d1uoof821imlo6.cloudfront.net/wp-content/plugins/youtube-embed-plus/scripts/fitvids.min.js?ver=4.9.4'></script>
<script type='text/javascript' src='//d1uoof821imlo6.cloudfront.net/wp-includes/js/wp-embed.min.js?ver=4.9.4'></script>
<script type="text/css" id="tmpl-tribe_customizer_css">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</script><style type="text/css" id="tribe_customizer_css">.tribe-events-calendar td.tribe-events-present div[id*="tribe-events-daynum-"],
#tribe_events_filters_wrapper input[type=submit],
.tribe-events-button,
#tribe-events .tribe-events-button,
.tribe-events-button.tribe-inactive,
#tribe-events .tribe-events-button:hover,
.tribe-events-button:hover,
.tribe-events-button.tribe-active:hover {
background-color: #9d2776;
}
#tribe-events-content .tribe-events-tooltip h4,
#tribe_events_filters_wrapper .tribe_events_slider_val,
.single-tribe_events a.tribe-events-ical,
.single-tribe_events a.tribe-events-gcal {
color: #9d2776;
}
.tribe-grid-allday .tribe-events-week-allday-single,
.tribe-grid-body .tribe-events-week-hourly-single,
.tribe-grid-allday .tribe-events-week-allday-single:hover,
.tribe-grid-body .tribe-events-week-hourly-single:hover {
background-color: #9d2776;
border-color: rgba(0, 0, 0, 0.3);
}
.tribe-events-list .tribe-events-loop .tribe-event-featured,
.tribe-events-list #tribe-events-day.tribe-events-loop .tribe-event-featured,
.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap,
.type-tribe_events.tribe-events-photo-event.tribe-event-featured .tribe-events-photo-event-wrap:hover {
background-color: #0ea0d7;
}
#tribe-events-content table.tribe-events-calendar .type-tribe_events.tribe-event-featured {
background-color: #0ea0d7;
}
.tribe-events-list-widget .tribe-event-featured,
.tribe-events-venue-widget .tribe-event-featured,
.tribe-mini-calendar-list-wrapper .tribe-event-featured,
.tribe-events-adv-list-widget .tribe-event-featured .tribe-mini-calendar-event {
background-color: #0ea0d7;
}
.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single {
background-color: rgba(14,160,215, .7 );
border-color: #0ea0d7;
}
.tribe-grid-body .tribe-event-featured.tribe-events-week-hourly-single:hover {
background-color: #0ea0d7;
}
.tribe-button {
background-color: #0ea0d7;
color: #fff;
}
.tribe-button:hover,
.tribe-button:active,
.tribe-button:focus {
background-color: #096b8f;
}
#tribe-events .tribe-event-featured .tribe-button:hover {
color: #053547;
}
#tribe-events-content a,
.tribe-events-event-meta a {
color: #9d2776;
}
#tribe_events_filters_wrapper input[type=submit],
.tribe-events-button,
#tribe-events .tribe-events-button,
.tribe-events-button.tribe-inactive,
#tribe-events .tribe-events-button:hover,
.tribe-events-button:hover,
.tribe-events-button.tribe-active:hover {
background-color: #9d2776;
}
#tribe-events .tribe-events-calendar td.tribe-events-othermonth,
#tribe-events .tribe-grid-allday,
#tribe-events .tribe-week-today,
#tribe-events .tribe-events-calendar td:hover {
background-color: #f1f1f1;
}
#tribe-events .tribe-events-calendar td,
#tribe-events .tribe-week-grid-block div,
#tribe-events .tribe-events-grid,
#tribe-events .tribe-grid-allday,
#tribe-events .tribe-events-grid .tribe-scroller,
#tribe-events .tribe-events-grid .tribe-grid-body .column,
#tribe-events .tribe-events-grid .tribe-grid-allday .column {
border-color: #d2d2d2;
}
.events-archive.events-gridview #tribe-events-content table .type-tribe_events,
.tribe-events-shortcode .tribe-events-month table .type-tribe_events {
border-color: #e4e4e4;
}
.tribe-events-calendar td.tribe-events-past div[id*="tribe-events-daynum-"],
.tribe-events-calendar td.tribe-events-past div[id*="tribe-events-daynum-"] > a {
background-color: #d2d2d2;
}
.tribe-events-calendar div[id*="tribe-events-daynum-"],
.tribe-events-calendar div[id*="tribe-events-daynum-"] a {
background-color: #acacac;
}
.tribe-events-calendar thead th,
.tribe-events-grid .tribe-grid-header .tribe-grid-content-wrap .column,
.tribe-grid-header {
background-color: #464646;
border-left-color: #464646;
border-right-color: #464646;
}
#tribe-events td.tribe-events-present div[id*="tribe-events-daynum-"],
#tribe-events td.tribe-events-present div[id*="tribe-events-daynum-"] > a {
background-color: #9d2776;
color: #fff;
}
#tribe-events .tribe-events-grid .tribe-grid-header div.tribe-week-today {
background-color: #9d2776;
}
.tribe-grid-allday .tribe-events-week-allday-single,
.tribe-grid-body .tribe-events-week-hourly-single,
.tribe-grid-allday .tribe-events-week-allday-single:hover,
.tribe-grid-body .tribe-events-week-hourly-single:hover {
background-color: #9d2776;
background-color: rgba( 157, 39, 118, .75 );
border-color: #601848
}
.single-tribe_events .tribe-events-event-meta {
background-color: #9d2776;
color: #f9f9f9;
}
.tribe-events-single-event-title {
color: #333;
}</style>
<script>
(function() {
"use strict";
//variables
var searchInput;
var date;
var oldestDate;
var newestDate;
var listDate;
var button;
var bigButton;
var results;
var month;
var year;
var pdfs;
var filePath;
window.addEventListener("load", onStartup);
// ------------------------------------------------------- private methods
function readyMe() {
//need to know current year to fill year list
while (oldestDate <= newestDate) {
listDate += "<option>" + newestDate + "</option>";
newestDate--;    
}
//populate year list
year.innerHTML = listDate;
//need to know the current month and select it by default
month.options[date.getMonth()].selected = "selected";
//do an initial search based on current date
doSearch();
}
// ------------------------------------------------------- event handlers
function onStartup(e) {
date = new Date();
oldestDate = 2005;
newestDate = date.getFullYear();
listDate = "";
searchInput = document.getElementById("searchInput");
button = document.getElementById("btnMYsearch");
bigButton = document.getElementById("btnBigSearch");
results = document.getElementById("lblResults");
month = document.getElementById("lstMonth");
year = document.getElementById("lstYear");
pdfs = document.getElementById("txtPDFs");
filePath = "";
readyMe();
button.addEventListener("click", doSearch);
bigButton.addEventListener("click", doBigSearch);
}
document.querySelector('#searchInput').addEventListener('keypress', function (e) {
var key = e.which || e.keyCode;
if (key === 13) { // 13 is enter
//if enter key is pressed while typing in search bar
doBigSearch();
}
});
function doSearch() {
//always clear previous list first if any
pdfs.innerHTML = "";
//send request to server to get archived list
var xhttp = new XMLHttpRequest();
console.log("TEST1");
xhttp.onreadystatechange = function() {
if (this.readyState == 4 && this.status == 200) {
//if inside this if, request was successful - now to do work
var response = this.responseText;
//split the response into an array that can be used
var responseArry = response.split(/\.pdf/i);
//flag is simply to determine and tell user if there are no papers on the selected date
var flag = false;
console.log("TEST2");
//loop through all papers and find which ones the user wants
for (var i=0; i<=(responseArry.length-1); i++) {
if (responseArry[i].includes(month.options[month.selectedIndex].id) && responseArry[i].includes(year.options[year.selectedIndex].innerText)) {
//if month and year user selects matches a paper, grab it, for all days of that month and year
pdfs.innerHTML += '<div style="margin:10px;border:1px solid #ccc;width:100px;float:left;"><a href="//enfieldweeklypress.com/wp-content/uploads/Archives/PDFs/'+responseArry[i]+'.pdf'+'" style="color:#9d2776;" target="_blank"><img src="//enfieldweeklypress.com/wp-content/uploads/Archives/THUMBs/'+responseArry[i]+'.jpg" alt="'+responseArry[i]+'" style="width:100%;height:auto;"><h6 style="text-align:center;margin-top:1px;">'+responseArry[i].replace(/-/g, " ")+'</h6></a></div>';
flag = true;
console.log("TEST3");
} 
}
if (flag === false) {
//if this is the case, their are no matches for the selected date - let user know
pdfs.innerHTML = "<h5>Sorry, No Papers Archived on this Date</h5>";
}
console.log(this.responseText);
}
};
xhttp.open("GET", "../wp-content/uploads/Archives/PDFs/WordpressYearMonthDropdown.php", true);
xhttp.send();
}
function doBigSearch() {
//output temp message so user knows the button works
results.innerHTML = "Please Wait, Searching...<i class='fa fa-refresh fa-spin'></i>";
//send request to server to get archived list
var xhttp = new XMLHttpRequest();
xhttp.onreadystatechange = function() {
console.log("Input: " + searchInput.value);
if (this.readyState == 4 && this.status == 200) {
//if inside this if, request was successful - now to clear timeout and show response
clearTimeout(xmlHttpTimeout);
var response = this.responseText;
results.innerHTML = response;
console.log("Result: " + response);
}
};
xhttp.open("POST", "../wp-content/uploads/Archives/TXTs/SearchBarTest.php", true);
xhttp.setRequestHeader("Content-type", "application/x-www-form-urlencoded");
xhttp.send("searchInput=" + searchInput.value);
//check for timeout and abort if over 30 seconds
var xmlHttpTimeout=setTimeout(ajaxTimeout,30000);
function ajaxTimeout(){
xhttp.abort();
results.innerHTML = "Sorry, word/phrase to common. Please try to narrow your search more!";
}
}
}());
</script>
</body>
</html><!-- WP Fastest Cache file was created in 0.69658493995667 seconds, on 01-03-18 18:27:42 -->